archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-iniconfig / trunk / PKGBUILD
blobe81f5b4afd57909475c269cf07c19c2670f600be
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-iniconfig
4 pkgver=2.0.0
5 _commit=93f5930e668c0d1ddf4597e38dd0dea4e2665e7a
6 pkgrel=4
7 pkgdesc="brain-dead simple config-ini parsing"
8 url="https://github.com/RonnyPfannschmidt/iniconfig"
9 license=('MIT')
10 arch=('any')
11 depends=('python')
12 makedepends=('git' 'python-build' 'python-installer' 'python-hatchling' 'python-hatch-vcs')
13 checkdepends=('python-pytest')
14 source=("git+https://github.com/RonnyPfannschmidt/iniconfig.git#commit=$_commit")
15 sha512sums=('SKIP')
17 build() {
18   cd iniconfig
19   python -m build -nw
22 check() {
23   cd iniconfig
24   PYTHONPATH="$PWD/src" pytest
27 package() {
28   cd iniconfig
29   python -m installer --destdir="$pkgdir" dist/*.whl
30   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/