1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=python-ipycanvas
4 _pyname=${pkgname#python-}
7 pkgdesc="Interactive widgets library exposing the browser's Canvas API"
8 url='https://github.com/martinRenou/ipycanvas'
11 source=(https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz)
12 depends=(python-ipywidgets python-pillow python-numpy python-setuptools)
13 makedepends=(python-build python-installer python-jupyter_packaging jupyterlab)
14 sha256sums=('f9c3940681bc38383390f8c46ea5d8445d6e11c6da6484c37d89df5ae1dac131')
18 python -m build --wheel --no-isolation --skip-dependency-check
23 python -m installer --destdir="$pkgdir" dist/*.whl
24 install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
25 mv "$pkgdir"/{usr/,}etc