1 # Maintainer: kpcyrd <kpcyrd[at]archlinux[dot]org>
4 pkgname=python-${_pyname}
7 pkgdesc='Simple streaming JSON parser'
9 url="https://github.com/daggaz/json-stream"
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
14 b2sums=('d18e3356bbf900e71250a55377ad76bbfd552ea6eea90d2b1d89e84733b0c507cbc507747bed123682ee9a3fc3f167b2fe27be3925c6809c60a02bc236a0db87')
17 cd "${_pyname}-${pkgver}"
18 python -m build --wheel --no-isolation
22 cd "${_pyname}-${pkgver}"
23 python -m installer --destdir="${pkgdir}" dist/*.whl
24 install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"