archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-jsonlines / repos / community-any / PKGBUILD
blobcc9188fd29d589062d1325238a7e1a50eecf239f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-jsonlines
4 pkgver=3.1.0
5 pkgrel=2
6 pkgdesc="Library with helpers for the jsonlines file format"
7 url="https://github.com/wbolster/jsonlines"
8 license=('BSD')
9 arch=('any')
10 depends=('python-attrs')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest')
13 source=("https://github.com/wbolster/jsonlines/archive/$pkgver/$pkgname-$pkgver.tar.gz")
14 sha512sums=('f5fd35bbdc94106afbf8f837bcc3440348772f3b6011b2fb8d7cf86a8ec881c5350aebcd3ae85d45ec88b8deddc68c8e417eaf172f7777c009e42beb7f64ff61')
16 build() {
17   cd jsonlines-$pkgver
18   python setup.py build
21 check() {
22   cd jsonlines-$pkgver
23   python -m pytest
26 package() {
27   cd jsonlines-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
29   install -Dm644 LICENSE.rst -t "$pkgdir"/usr/share/licenses/$pkgname/