1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-jsonschema-objects
6 pkgdesc="Return the jsonschema-objects true value of an iterable"
7 url="https://github.com/cwacek/python-jsonschema-objects"
10 depends=('python-inflection' 'python-markdown' 'python-jsonschema' 'python-six')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner' 'python-pytest-mock')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/cwacek/python-jsonschema-objects/archive/$pkgver.tar.gz"
14 $pkgname-nested-oneof-resolution-and-markdown.patch::https://github.com/cwacek/python-jsonschema-objects/pull/233.patch)
15 sha512sums=('4f47424741aa918e514f2570d316fab9feccc0e0860fe5fc6b863d2a75d4f109f80eb03e4f52549e075e83ebbd2ebceab95c5b43966650993e9bb59e94e02b63'
16 'bd9543edd369eb5941cc7831e2a4c939c2e6a163e60525b72fa021b8f75c7c7b0d0bd05fe6ee3c5cfbdaac0fe47c93daf55a72b18954b7dcf6e343f4049ce579')
19 cd python-jsonschema-objects-$pkgver
20 patch -p1 < ../$pkgname-nested-oneof-resolution-and-markdown.patch
24 cd python-jsonschema-objects-$pkgver
29 cd python-jsonschema-objects-$pkgver
30 python setup.py pytest --addopts --doctest-glob='python_jsonschema_objects/*.md'
34 cd python-jsonschema-objects-$pkgver
35 python setup.py install --root="$pkgdir" --optimize=1
37 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/