archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-jupyter-ydoc / trunk / PKGBUILD
blobaad7c3fdb882056eef423be462cda7c619f92ef6
1 # Maintainer: Antonio Rojas <arojas@archlinux.com>
3 _pyname=jupyter_ydoc
4 pkgname=python-${_pyname//_/-}
5 pkgver=1.0.2
6 pkgrel=2
7 pkgdesc='Document structures for collaborative editing using Ypy'
8 arch=(any)
9 url='https://jupyter.org/'
10 license=(MIT)
11 depends=(python-ypy-websocket)
12 makedepends=(python-build python-installer python-hatchling python-hatch-nodejs-version)
13 checkdepends=(python-pytest-asyncio python-websockets)
14 source=(https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz)
15 sha256sums=('0f95bede3f1e081e07d5c57c03c658e3a5247e0ef18889074fbefa20dd3eca53')
17 build() {
18   cd $_pyname-$pkgver
19   python -m build --wheel --no-isolation
22 #check() {
23 #  cd $_pyname-$pkgver
24 #  python -m venv --system-site-packages test-env
25 #  test-env/bin/python -m installer dist/*.whl
26 #  test-env/bin/python -m pytest -v
29 package() {
30   cd $_pyname-$pkgver
31   python -m installer --destdir="$pkgdir" dist/*.whl
32   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname