archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-keycloak / trunk / PKGBUILD
blobe980cec161b1861242712b16bbc108d0c15df90e
1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 pkgname=python-keycloak
4 pkgver=2.7.0
5 pkgrel=1
6 pkgdesc='Python package providing access to the Keycloak API'
7 arch=('any')
8 url='https://github.com/marcospereirampj/python-keycloak'
9 license=('MIT')
10 depends=('python' 'python-requests' 'python-requests-toolbelt' 'python-jose' 'python-urllib3')
11 makedepends=(python-build python-installer python-wheel python-poetry-core)
12 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/marcospereirampj/python-keycloak/archive/refs/tags/v${pkgver}.tar.gz)
13 sha256sums=('290df9db8bc8a39c1f35cc76614c49f0ec38caf8f0ad8e5e43c9e65ac8d20e9a')
15 prepare() {
16   cd "$pkgname-$pkgver"
19 build() {
20   cd "$pkgname-$pkgver"
21   python -m build --wheel --no-isolation
24 package() {
25   cd "${pkgname}-${pkgver}"
27   python -m installer --destdir="$pkgdir" dist/*.whl
28   install -D -m644 LICENSE \
29     "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
32 check() {
33   cd "${pkgname}-$pkgver"
35   # requires: python-httmock
36 #python3 setup.py test