1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Joakim Hernberg <jhernberg@alchemy.lu>
3 # Contributor: Ninez <triplesquarednine@gmail.com>
5 pkgname=python-linux-procfs
8 pkgdesc="Linux /proc abstraction classes for python"
10 url="https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/python-linux-procfs.git/"
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 source=(https://git.kernel.org/pub/scm/libs/python/$pkgname/$pkgname.git/snapshot/$pkgname-$pkgver.tar.gz)
15 sha512sums=('47b54e2a79e427eff1b92c7da80e8d307ba0e89f743388d937bc8be8d28ccc71fe76e7731571d96338a9318daec7f25ca4e2809c54c0fe82d772538d5a5209c5')
16 b2sums=('e106d2fc6c7527a3276a4603bcff8ed0ba6604a352912c64ff913e2e7309c78c936a463aaa6512a718961d5dcc56c18d2a687f9ffa74ace6d0991114293be832')
20 python -m build --wheel --no-isolation
25 python bitmasklist_test.py
30 python -m installer --destdir="$pkgdir" dist/*.whl