archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-lockfile / repos / community-any / PKGBUILD
blob32612c4612eae9ea59f07dc0a66caf660fc476e6
2 pkgbase=python-lockfile
3 pkgname=(python-lockfile)
4 pkgver=0.12.2
5 pkgrel=12
6 pkgdesc='Platform-independent file locking module'
7 arch=(any)
8 url='https://github.com/openstack/pylockfile'
9 license=(MIT)
10 depends=(python)
11 makedepends=(python-setuptools python-pbr)
12 checkdepends=(python-nose)
13 source=(https://files.pythonhosted.org/packages/source/l/lockfile/lockfile-$pkgver.tar.gz)
14 sha256sums=('6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799')
16 prepare() {
17   cp -a lockfile-$pkgver{,-py2}
20 build() {
21   cd "$srcdir/lockfile-$pkgver"
22   python setup.py build
25 check() {
26   cd "$srcdir/lockfile-$pkgver"
27   nosetests
30 package() {
31   cd "$srcdir/lockfile-$pkgver"
32   python setup.py install --root="$pkgdir" --optimize=1
33   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"