archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-lru-dict / trunk / PKGBUILD
blob3e6341e2ef6d1b3f625b7c51856ee2a502f910d1
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Guillaume Horel <guillaume.horel@gmail.com>
4 pkgname=python-lru-dict
5 pkgver=1.1.8
6 pkgrel=2
7 pkgdesc='A fast and memory efficient LRU cache for Python'
8 arch=(x86_64)
9 url=https://github.com/amitdev/lru-dict
10 license=(MIT)
11 depends=(python)
12 makedepends=(
13   git
14   python-setuptools
16 _tag=8bdcd75a11f629aff4b15ec0ae0faaf165a44fb1
17 source=(git+https://github.com/amitdev/lru-dict.git#tag=${_tag})
18 b2sums=(SKIP)
20 pkgver() {
21   cd lru-dict
22   git describe --tags | sed 's/^v//'
25 build() {
26   cd lru-dict
27   python setup.py build_ext
30 package() {
31   cd lru-dict
32   python setup.py install --root="${pkgdir}" --optimize=1
33   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-lru-dict/
36 # vim: ts=2 sw=2 et: