archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-lupa / repos / community-x86_64 / PKGBUILD
blob1ce6dd3e9bf2a91c449dec9e9c39da51a9b152c2
1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Eli Schwartz <eschwartz@archlinux.org>
4 _pkgname=lupa
5 pkgname=python-lupa
6 pkgver=2.0
7 pkgrel=2
8 pkgdesc='Python wrapper around Lua and LuaJIT'
9 arch=(x86_64)
10 url="https://github.com/scoder/$_pkgname"
11 license=(MIT)
12 depends=(python)
13 makedepends=(python-{build,installer,wheel}
14              python-setuptools)
15 _archive="$_pkgname-$pkgver"
16 source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_archive.tar.gz")
17 sha256sums=('ad3fef486be7adddd349fe9a9c393789061312cf98ebc533b489be34f484cb79')
19 build() {
20         cd "$_archive"
21         python -m build -wn
24 check() {
25         cd "$_archive"
26         local _pyver=cpython-$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
27         cd "$PWD/build/lib.linux-$CARCH-$_pyver"
28         python -m unittest discover
31 package() {
32         cd "$_archive"
33         python -m installer -d "$pkgdir" dist/*.whl
34         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.txt