archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-marshmallow / repos / community-any / PKGBUILD
blob4385e3e082db1e4185cc3ff6783c465a2c01cdef
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-marshmallow
4 pkgver=3.19.0
5 pkgrel=2
6 pkgdesc="A lightweight library for converting complex datatypes to and from native Python datatypes."
7 url="https://github.com/marshmallow-code/marshmallow"
8 license=('MIT')
9 arch=('any')
10 depends=('python-packaging')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner' 'python-simplejson' 'python-pytz' 'python-dateutil')
13 source=("https://pypi.io/packages/source/m/marshmallow/marshmallow-$pkgver.tar.gz")
14 sha512sums=('aa621949aaa2ec00538422461f3866c44304ee3bdf55b94d90f45c8c1dcbb542050e1f2ba459eff40d1588b94c15d6a07a1c9e759fbb21e2bffe2414bc2a7151')
16 build() {
17   cd "$srcdir"/marshmallow-$pkgver
18   python setup.py build
21 check() {
22   cd "$srcdir"/marshmallow-$pkgver
23   python setup.py pytest
26 package() {
27   cd marshmallow-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1
29   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE