1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
4 # Contributor: Stefan Husmann <stefan-husmann@t-online.de>
5 # Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
6 # Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
8 pkgname=python-matplotlib
11 pkgdesc="A python plotting library, making publication quality plots"
13 url="https://matplotlib.org"
15 depends=(freetype2 python-contourpy python-cycler python-dateutil python-fonttools python-kiwisolver python-numpy
16 python-packaging python-pillow python-pyparsing qhull)
17 optdepends=('tk: Tk{Agg,Cairo} backends'
18 'pyside2: alternative for Qt5{Agg,Cairo} backends'
19 'pyside6: alternative for Qt6{Agg,Cairo} backends'
20 'python-pyqt5: Qt5{Agg,Cairo} backends'
21 'python-pyqt6: Qt6{Agg,Cairo} backends'
22 'python-gobject: for GTK{3,4}{Agg,Cairo} backend'
23 'python-wxpython: WX{Agg,Cairo} backend'
24 'python-cairo: {GTK{3,4},Qt{5,6},Tk,WX}Cairo backends'
25 'python-cairocffi: alternative for Cairo backends'
26 'python-tornado: WebAgg backend'
27 'ffmpeg: for saving movies'
28 'imagemagick: for saving animated gifs'
29 'ghostscript: usetex dependencies'
30 'texlive-bin: usetex dependencies'
31 'texlive-latexextra: usetex usage with pdflatex'
32 'python-certifi: https support')
33 makedepends=(git python-build python-installer python-certifi python-setuptools-scm pybind11 python-wheel)
34 checkdepends=(python-pytest python-pytest-xdist python-pytest-runner python-pytest-rerunfailures xorg-server-xvfb
35 texlive-bin texlive-core texlive-latexextra texlive-pictures
36 ghostscript inkscape ffmpeg imagemagick gtk4
37 python-cairo python-cairocffi python-gobject python-pyqt5 pyside2
38 python-pyqt6 pyside6 python-tornado python-wxpython tk
39 jupyter-nbconvert jupyter-nbformat python-ipykernel
40 python-pandas python-pikepdf python-pytz python-xarray
41 noto-fonts-cjk wqy-zenhei)
42 _tag=8dcbd965f3008b6dc324f4a45b65ff580e55090e # git rev-parse v${pkgver}
44 source=(git+https://github.com/matplotlib/matplotlib.git#tag=${_tag}?signed
45 https://github.com/QuLogic/mpl-images/archive/v${pkgver}-with-freetype-${_ftver}/mpl-images-${pkgver}-ft${_ftver}.tar.gz
47 matplotlib-fix-pgf-tests.patch::https://github.com/matplotlib/matplotlib/pull/25068.patch)
49 'bcbf789be86c399e7bf08b8647622c4b97e905da7e58a41f5fce9cfdf3941aadf3cf5cb9bb8a417c5640c7e2d5409abffa63fe5a6e68a4b543caf0855acf25e9'
50 'b821f938cace434932a43b15b42b93d0f8eaffea4e28fbf1d5a7263ec947c26252bafccaea60c1a1cb2fad4c71280ca2cf62527994f270af2467a242287470bb'
51 'fcbc1a8a73f37549fd0f9d62b6312f51d3c00ce64f325498b997977db2ce1f57d2edd7b94fca78849c0a0677bc14fa424bbb5e0ef1556e8a0626d8756191f7ad')
52 validpgpkeys=(23CAB59E3332F94D26BEF0378D86E7FAE5EB0C10) # Elliott Sales de Andrade <quantum.analyst@gmail.com>
56 # Fix SCM detected version
58 # Don't require oldest-supported-numpy
59 sed -e 's|oldest-supported-numpy|numpy|' -i pyproject.toml
60 # Use system freetype and qhull
61 sed -e 's|#system_freetype = False|system_freetype = True|' -e 's|#system_qhull = False|system_qhull = True|' mplsetup.cfg.template > mplsetup.cfg
62 patch -p1 < ../freetype.patch # From Fedora/upstream
63 sed -e 's|2_000_000|2_500_000|' -i lib/matplotlib/tests/test_backends_interactive.py
64 # Install tests for check()
65 sed -i 's|#tests = False|tests = True|' mplsetup.cfg
66 # Use appropriate baseline images for tests
67 for _module in matplotlib mpl_toolkits
69 cp -r ../mpl-images-${pkgver}-with-freetype-${_ftver}/lib/${_module}/* lib/${_module}
71 git apply ../matplotlib-fix-pgf-tests.patch
76 export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
77 python -m build --wheel --no-isolation
82 export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
83 python -m venv --system-site-packages test-env
84 test-env/bin/python -m installer dist/*.whl
85 # test_ipynb: https://github.com/matplotlib/matplotlib/issues/21654 fixed but `ModuleNotFoundError: No module named 'matplotlib'`
86 # test_compressed1: https://github.com/QuLogic/mpl-images/issues/4
87 XDG_RUNTIME_DIR=/tmp/runtime-build \
88 xvfb-run -a -s "-screen 0 640x480x24" \
89 test-env/bin/python -m pytest -ra -n auto -v --color=yes --pyargs matplotlib mpl_toolkits.{axes_grid1,axisartist,mplot3d} \
90 -k 'not test_ipynb and not test_compressed1 and not test_multi_font_type3 and not test_multi_font_type42 and not test_figure_legend_outside' || true
95 export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
96 python -m installer --destdir="${pkgdir}" dist/*.whl
97 install -Dm644 doc/users/project/license.rst -t "${pkgdir}"/usr/share/licenses/${pkgname}/
99 rm -r "${pkgdir}"$(python -c "import site; print(site.getsitepackages()[0])")/{matplotlib,mpl_toolkits/*}/tests/