1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Letu Ren <fantasquex at gmail dot com>
5 pkgname=python-${_pyname}
8 pkgdesc='Module that multiplexes interactions with lists of python objects'
9 url='https://github.com/zardus/mulpyplexer'
11 license=('custom:BSD')
13 makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
14 source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
15 sha512sums=('d7df91b3ed606a0865cd7df815de8971354b372d2bbca20529cf7ac6492dc4607fc20a3587431c86c4d1d3eb1a59cde4796bc7a0b4421443086f24b42b86cd2b')
16 b2sums=('3918dee824f0aee8c95562fa29c1e3ed64c7d37844f81078e7e2883f1e4d994f9a996c798e4f5f5a12afa5cd40ec09a0b942b89fe5c52183898c20038b8fbe4b')
19 cd ${_pyname}-${pkgver}
20 python -m build --wheel --no-isolation
24 cd ${_pyname}-${pkgver}
25 python -m installer --destdir="$pkgdir" dist/*.whl
26 install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
27 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"