archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-nine / repos / community-any / PKGBUILD
blob5863bdb1b1d298aa958a98d165eed0d1585af708
1 # Maintainer: Thore Bödecker <foxxx0@archlinux.org>
2 # Contributor: Maikel Wever <maikelwever@gmail.com>
3 pkgname='python-nine'
4 _pkgbase="${pkgname#python-}"
5 pkgver=1.1.0
6 pkgrel=7
7 arch=('any')
8 pkgdesc="Python 3/2 compatibility library, allowing to add py2 compat to py3 code"
9 url="https://github.com/nandoflorestan/nine/"
10 license=('custom')
11 depends=('python')
12 makedepends=('python-setuptools')
13 source=("${_pkgbase}-${pkgver}.tar.gz::https://github.com/nandoflorestan/nine/archive/v${pkgver}.tar.gz")
14 sha512sums=('b445cd1f324a0d2045081226fb650eebd8dbc86942faff204c19fffc022f0190fc04abec563b107cb860202d29f08c132056b1098495471fdfda104e57878828')
16 check() {
17   cd "${srcdir}/${_pkgbase}-${pkgver}"
18   python -m unittest discover -vs .
21 package() {
22   cd "${srcdir}/${_pkgbase}-${pkgver}"
23   python ./setup.py install --root="$pkgdir/" --optimize=1
24   install -D -m0644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"