1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
3 _pkgname=pythonocc-core
4 pkgname=python-${_pkgname#python}
6 _commit=09d3747dbf6384f94d83ff2171e09259567823ff
8 pkgdesc='Python package for 3D CAD/BIM/PLM/CAM'
10 url='https://github.com/tpaviot/pythonocc-core'
12 depends=('python' 'opencascade' 'libxmu' 'libxi')
13 # rapidjson appears to be unused but an opencascade
14 # header that references it gets dragged in somehow
15 makedepends=('cmake' 'swig' 'rapidjson' 'git' 'ninja')
16 #source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
17 source=("git+https://github.com/tpaviot/pythonocc-core#commit=$_commit")
22 git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
26 mv $_pkgname $_pkgname-$pkgver
29 # Compatibility with opencascade 7.6.3
30 git cherry-pick -n b4ddcf774549dbb3f89f4ca9f9c5db6c3c9ab48c
39 -DCMAKE_INSTALL_PREFIX=/usr \
40 -DCMAKE_BUILD_TYPE=Release
48 DESTDIR="$pkgdir" ninja -C build install