archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-odfpy / trunk / PKGBUILD
blobee99d1f1bbc28974b0b7ae26084b811b09dc77e0
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Maintainer: Brett Cornwall <ainola@archlinux.org>
3 # Contributor: Eduardo Parra Mazuecos <eduparra90@gmail.com>
5 pkgname=python-odfpy
6 pkgver=1.4.2
7 pkgrel=4
8 pkgdesc='Python API and tools to manipulate OpenDocument files'
9 arch=('any')
10 url='https://github.com/eea/odfpy'
11 license=('Apache' 'GPL')
12 depends=('python-defusedxml')
13 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
14 checkdepends=('python-pytest')
15 source=("https://github.com/eea/odfpy/archive/release-$pkgver/$pkgname-$pkgver.tar.gz")
16 sha256sums=('24ad087f38031b2fe60bf22811b9550887afe1cfdea80672d6573387c3025583')
18 build() {
19   cd odfpy-release-$pkgver
20   python -m build --wheel --no-isolation
23 check() {
24   cd odfpy-release-$pkgver
25   PYTHONPATH=. pytest
28 package() {
29   cd odfpy-release-$pkgver
30   python -m installer --destdir="$pkgdir" dist/*whl