1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Maintainer: Brett Cornwall <ainola@archlinux.org>
3 # Contributor: Eduardo Parra Mazuecos <eduparra90@gmail.com>
8 pkgdesc='Python API and tools to manipulate OpenDocument files'
10 url='https://github.com/eea/odfpy'
11 license=('Apache' 'GPL')
12 depends=('python-defusedxml')
13 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
14 checkdepends=('python-pytest')
15 source=("https://github.com/eea/odfpy/archive/release-$pkgver/$pkgname-$pkgver.tar.gz")
16 sha256sums=('24ad087f38031b2fe60bf22811b9550887afe1cfdea80672d6573387c3025583')
19 cd odfpy-release-$pkgver
20 python -m build --wheel --no-isolation
24 cd odfpy-release-$pkgver
29 cd odfpy-release-$pkgver
30 python -m installer --destdir="$pkgdir" dist/*whl