1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
4 pkgname=python-$_pkgname
7 pkgdesc='Experimental library aimed at consolidating a lot of our low-level code used for Enthought eggs'
9 url='https://github.com/enthought/okonomiyaki'
11 depends=('python' 'python-attrs' 'python-jsonschema' 'python-six')
12 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
13 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
14 sha512sums=('89877ecca20370bcfd3f74429913e708a1e10f841fac012e154c4b43862dc9f1644d1b70638811cae71e5651565514db002ca777466b5e848009d7699b5735ed')
19 find -type f -name '*.py' -exec sed -i 's|zipfile2|zipfile|' '{}' +
20 sed -i /zipfile2/d setup.py
32 python -m installer -d "$pkgdir" dist/*.whl
34 install -Dm 644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37 # vim:set ts=2 sw=2 et: