archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-openstackdocstheme / trunk / PKGBUILD
blob2d89a0901d28d9c129de4ad38468e02df498fe66
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=python-openstackdocstheme
5 pkgver=3.1.0
6 _commit=20bf587d68f6c1794168f2ad467c9c55daf074e5
7 pkgrel=2
8 pkgdesc="Open Infrastructure Projects Sphinx Themes"
9 arch=('any')
10 url="https://opendev.org/openstack/openstackdocstheme"
11 license=('Apache')
12 depends=('python-pbr' 'python-dulwich' 'python-sphinx')
13 makedepends=('git' 'python-setuptools')
14 options=('!emptydirs')
15 source=("git+https://github.com/openstack/openstackdocstheme.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd openstackdocstheme
20   python setup.py build
21   PYTHONPATH="$PWD/build/lib" sphinx-build -W -b man doc/source doc/build/man
24 package() {
25   cd openstackdocstheme
26   python setup.py install --root="$pkgdir" --optimize=1
27   install -Dm644 doc/build/man/*.1 -t "$pkgdir"/usr/share/man/man1/