archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-oslo-context / trunk / PKGBUILD
blob06ae92343845a539f40e9fa107232698789fd677
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
4 pkgname=python-oslo-context
5 pkgver=5.1.1
6 _commit=7696282cb5bead6d7c6320ff287fb635500bd9a6
7 pkgrel=2
8 pkgdesc="OpenStack Context library"
9 arch=('any')
10 url="https://pypi.python.org/pypi/oslo.context/$pkgver"
11 license=('Apache')
12 depends=('python-pbr' 'python-debtcollector')
13 makedepends=('git' 'python-setuptools')
14 checkdepends=('python-oslotest')
15 source=("git+https://github.com/openstack/oslo.context.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd oslo.context
20   python setup.py build
23 check() {
24   cd oslo.context
25   stestr run
28 package() {
29   cd oslo.context
30   python setup.py install --root="$pkgdir" --optimize=1
33 # vim:set ts=2 sw=2 et: