archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pam / trunk / PKGBUILD
blobbdd980fe30ce63110dddecf222c37676c0fd46c9
1 # Maintainer:
2 # Contributor: Eli Schwartz <eschwartz@archlinux.org>
4 pkgname=python-pam
5 pkgver=2.0.2
6 pkgrel=2
7 pkgdesc="Pure Python interface to the Pluggable Authentication Modules system on Linux"
8 arch=('any')
9 url="https://github.com/FirefighterBlu3/${pkgname}"
10 license=('MIT')
11 depends=('pam' 'python-six')
12 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
13 source=("https://files.pythonhosted.org/packages/source/${pkgname:0:1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
14 sha256sums=('97235235ba9b82dbae8068d1099508455949b275f77273ca22fdbd8b1fb5d950')
16 build() {
17   cd ${pkgname}-${pkgver}
18   python -m build --wheel --no-isolation
21 package() {
22   cd ${pkgname}-${pkgver}
24   python -m installer --destdir="${pkgdir}" dist/*.whl
25   install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"