1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
3 # Contributor: Limao Luo <luolimao+AUR@gmail.com>
8 pkgdesc="Python Build Reasonableness"
10 url='https://pypi.python.org/pypi/pbr'
12 depends=('python-importlib-metadata' 'python-setuptools')
13 makedepends=('python-build' 'python-installer' 'python-wheel')
14 checkdepends=('python-stestr' 'python-testscenarios' 'python-testresources' 'python-testrepository'
15 'python-virtualenv' 'python-wheel' 'python-sphinx' 'git')
16 source=("$pkgname-$pkgver.tar.gz::https://github.com/openstack-dev/pbr/archive/$pkgver.tar.gz")
17 sha512sums=('59ff86c3cc43cc824dfa448ff87fa1fcdd2561c269c63115777811934fd616c893f5fe727d5624eb624d42a43de386cc311c5c029520a3131d5144db5a891da4')
19 export PBR_VERSION=$pkgver
23 python -m build --wheel --no-isolation
28 # TODO: find out this failure
29 stestr run --exclude-regex "pbr.tests.test_packaging.TestPackagingWheels.test_metadata_directory_has_pbr_json"
34 python -m installer --destdir="$pkgdir" dist/*.whl
35 install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE