1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-poetry-dynamic-versioning
6 pkgdesc='Plugin for Poetry to enable dynamic versioning based on VCS tags'
8 url='https://github.com/mtkennerly/poetry-dynamic-versioning'
30 _commit='1ba52145bc6645e7efc049b0fb550acfd073780e'
31 source=("$pkgname::git+$url#commit=$_commit")
37 git describe --tags | sed 's/^v//'
43 python -m build --wheel --no-isolation
49 # integration tests are sketchy
50 pytest -v tests/test_unit.py
56 python -m installer --destdir="$pkgdir" dist/*.whl
59 install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE