archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-psutil / trunk / PKGBUILD
blobd266999f0fb532d7121176d0221fb6910285f2b1
1 # Maintainer: Sébastien Luttringer
3 pkgname=python-psutil
4 pkgver=5.9.5
5 pkgrel=1
6 arch=('x86_64')
7 pkgdesc='A cross-platform process and system utilities module for Python'
8 url='https://github.com/giampaolo/psutil'
9 license=('custom: BSD')
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('net-tools' 'procps-ng' 'python-pytest')
13 source=("https://github.com/giampaolo/psutil/archive/release-$pkgver.tar.gz")
14 sha512sums=('b9872acbecd1d9a9a79f032bd375ff0f10be4574e5f76f904c7a6367d7d3e24e7f0a1d06affa2fafbea74ecb594017029bdf29fdb8a8d37aeb51fb0016c3339c')
16 build() {
17   cd psutil-release-$pkgver
19   python setup.py build --build-lib=build/python
22 check() {
23   cd psutil-release-$pkgver
25   # Required for testing
26 #cp setup.py build/python
27 #cp -r scripts build/python/
29 # 4 non-working tests in build chroot, requires fixes. Test framework does not allow exclusion.
30 #  PYTHONPATH="$PWD/build/python" python psutil/tests/__main__.py
33 package() {
34   cd psutil-release-$pkgver
35   python setup.py build --build-lib=build/python \
36                   install --root="$pkgdir" --optimize=1
37   install -D -m 644 LICENSE "$pkgdir/"usr/share/licenses/$pkgname/LICENSE
40 # vim:set ts=2 sw=2 et: