1 # Maintainer: David Runge <dvzrv@archlinux.org>
4 pkgname=python-pylink-square
7 pkgdesc="Python interface for the SEGGER J-Link"
9 url="https://github.com/Square/pylink"
23 checkdepends=(python-pytest)
28 https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz
29 $pkgname-0.14.3-remove_mock.patch
31 sha512sums=('cbb222998fe52b69685734bd12423dae2828bcb19127060afef67cbb56df204e819c5359690854a528b44880fcee597c374356192841a54f20808de7846f23f2'
32 '35ff6497171de4acb6eebbca0619419ba8fa74da9487181dcbd90068fe2c7122e79d0d3e54dfc9a0bf010e398d144ff6ce20ca5e76e426269f6274b1d66287da')
33 b2sums=('7dbff8ea9d2ea478c6654402d112a503c6c3c856c9280b3b416c5c731860295f9e64d32d940a34fbb74ae5439afd555f719b3676827c3d16ae188ca3709e8256'
34 '4cc08b683975b3400caa0d73efb986737971c1003f1c0632d7440c25c9f0cc661f847275753c6ba03dc214e303a3cfd1ea8d3fb2bb6824c7560945fe1f2ecb05')
37 # remove use of mock: https://github.com/square/pylink/issues/149
38 patch -Np1 -d $_name-$pkgver -i ../$pkgname-0.14.3-remove_mock.patch
43 python -m build --wheel --skip-dependency-check --no-isolation
53 python -m installer --destdir="$pkgdir" dist/*.whl
54 install -vDm 644 *.md -t "$pkgdir/usr/share/doc/$pkgname"