archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pypcode / trunk / PKGBUILD
blobb1b1637ee5a44184dcccb47097974936206ef702
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Letu Ren <fantasquex at gmail dot com>
4 _pyname=pypcode
5 pkgname=python-${_pyname}
6 pkgver=1.1.2
7 pkgrel=1
8 pkgdesc="Python bindings to Ghidra's SLEIGH library for disassembly and lifting to p-code IR"
9 url='https://github.com/angr/pypcode'
10 license=('custom')
11 arch=('x86_64')
12 depends=('python' 'python-cffi')
13 makedepends=('cmake' 'python-build' 'python-installer' 'python-wheel' 'python-setuptools')
14 checkdepends=('python-pytest')
15 source=("${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
16 sha512sums=('e4f81de74fe96be3c1260ee025ffb72d53ffb9800a2c5a1ee61c810e92e13c0130cd988c6b60c26d4859154a90abbb611c63e922f1a2a661ea3649d5efd4ae4b')
17 b2sums=('9990dec2f605872204c199e51016e25d4aef6a1936656755a6db3977d534d3548b5e18cff4efe20360725ca5f16e546f4f37a7f874a2a8501f415f192cce8bc6')
19 build() {
20   cd ${_pyname}-${pkgver}
21   python -m build --wheel --no-isolation --skip-dependency-check
24 package() {
25   cd ${_pyname}-${pkgver}
26   python -m installer --destdir="$pkgdir" dist/*.whl
27   install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
28   install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
31 # vim: ts=2 sw=2 et: