1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
8 pkgdesc="Python interfaces to PROJ.4 library"
10 url="https://github.com/pyproj4/pyproj"
13 makedepends=(python-setuptools cython)
14 checkdepends=(python-pytest python-certifi python-numpy python-pandas python-shapely python-xarray)
15 source=(https://github.com/pyproj4/pyproj/archive/$pkgver/$pkgname-$pkgver.tar.gz)
16 sha256sums=('7cfd001b6af602cace31895c98a486e0570b8a2f4e7c8bb97a0e9f64e8cf029f')
20 sed -i 's/library_dirs if os.name.*/None/' pyproj-$pkgver/setup.py
29 # Import issues, no time to investigate
32 # local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
33 # PYTHONPATH="${PWD}"/build/lib.linux-$CARCH-${python_version} pytest -vv --color=yes
38 python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
39 install -Dm644 LICENSE_proj "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE