archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pyscipopt / trunk / PKGBUILD
blobacbdeb0285a2204932a0653974fe38ca81b1ddfb
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
4 pkgname=python-pyscipopt
5 pkgver=4.3.0
6 pkgrel=2
7 pkgdesc='A Python interface to the SCIP Optimization Suite'
8 arch=(x86_64)
9 url='https://www.scipopt.org/'
10 license=(MIT)
11 depends=(python scip)
12 makedepends=(cython python-build python-installer python-setuptools python-wheel)
13 source=(https://github.com/SCIP-Interfaces/PySCIPOpt/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('f2c71fdf9cdf4bbe2bdb3f26a1e3f5eb6d7a95e0c3dd6b7b31d4d5a910a191b2')
16 build() {
17   cd PySCIPOpt-$pkgver
18   python -m build --wheel --no-isolation
21 package() {
22   cd PySCIPOpt-$pkgver
23   python -m installer --destdir="$pkgdir" dist/*.whl