archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytest-aiohttp / trunk / PKGBUILD
blobab99b72bf2758cdc6896de4b962581dad880db67
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 _pkgname=pytest-aiohttp
4 pkgname=python-pytest-aiohttp
5 pkgver=1.0.4
6 pkgrel=3
7 pkgdesc='pytest plugin for aiohttp support'
8 url='https://github.com/aio-libs/pytest-aiohttp'
9 arch=('any')
10 license=('Apache')
11 depends=('python' 'python-pytest' 'python-aiohttp' 'python-py')
12 makedepends=('python-setuptools-scm')
13 #source=(${pkgname}-${pkgver}.tar.gz::https://github.com/aio-libs/pytest-aiohttp/archive/v${pkgver}.tar.gz)
14 source=(https://pypi.io/packages/source/p/$_pkgname/$_pkgname-$pkgver.tar.gz)
15 sha256sums=('39ff3a0d15484c01d1436cbedad575c6eafbf0f57cdf76fb94994c97b5b8c5a4')
16 sha512sums=('baf87e3aa229e8a4ab6746d277a923436ad2e0625825581c94a2fb0a9bbcd309bfc55186f8866589b65a75ccfd7d5b494d71554359724c0b2c9541ea94a177d8')
18 build() {
19   cd ${_pkgname}-${pkgver}
20   python setup.py build
23 package() {
24   cd ${_pkgname}-${pkgver}
25   python setup.py install --root="${pkgdir}" -O1 --skip-build
26   install -Dm 644 README.rst CHANGES.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
29 # vim: ts=2 sw=2 et: