archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytest-mpi / trunk / PKGBUILD
blob05663b6060f96d343ef2bc39ef820fd09dfc3d58
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 _pkg=pytest-mpi
4 pkgname=python-${_pkg}
5 pkgver=0.6
6 pkgrel=3
7 pkgdesc="pytest plugin for working with MPI"
8 arch=(any)
9 url="https://pytest-mpi.readthedocs.io/"
10 license=(BSD)
11 depends=(python-pytest)
12 makedepends=(python-setuptools)
13 checkdepends=(openmpi python-mpi4py python-sybil python-pytest-mpi)
14 source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
15 #source=(${url}/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz)
16 sha256sums=('09b3cd3511f8f3cd4d205f54d4a7223724fed0ab68b872ed1123d312152325a9')
18 build() {
19   cd ${_pkg}-${pkgver}
20   python setup.py build
23 check() {
24   cd ${_pkg}-${pkgver}
25   PYTHONPATH="${PWD}"/build/lib pytest -vv --color=yes tests -p pytester --runpytest=subprocess
28 package() {
29   cd ${_pkg}-${pkgver}
30   python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
31   install -Dm644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}