archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytest-param-files / repos / community-any / PKGBUILD
blobd2239f3f2303f3611c5550475b788f5116acdc9f
1 # Maintainer: Caleb Maclennana <caleb@alerque.com>
3 BUILDENV+=(!check)
5 pkgname=python-pytest-param-files
6 _pyname=${pkgname#python-}
7 pkgver=0.3.5
8 pkgrel=2
9 pkgdesc='Create pytest parametrize decorators from external files '
10 arch=(any)
11 url="https://github.com/chrisjsewell/$_pyname"
12 license=(MIT)
13 depends=(python
14          python-pytest)
15 makedepends=(python-{build,installer,wheel}
16              python-flit-core)
17 _archive="${_pyname//-/_}-$pkgver"
18 source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
19 sha256sums=('33e5b7ef41a7e89d9c04749156062701d9a4ef39fa0805741adb4f31765a6da5')
21 build() {
22         cd "$_archive"
23         python -m build -wn
26 check() {
27         cd "$_archive"
28         pytest
31 package() {
32         cd "$_archive"
33         python -m installer -d "$pkgdir" dist/*.whl
34         install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE