1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=python-pytest-pylint
7 pkgdesc='pytest plugin to check source code with pylint'
10 url='https://github.com/carsongee/pytest-pylint'
11 depends=('python-pytest' 'python-pylint' 'python-toml')
12 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/carsongee/pytest-pylint/archive/v$pkgver.tar.gz")
14 sha512sums=('94503757bf774ffbba56687cda7689a95748fe437759e29868105bc5f639b03782308c8e86eae7236ab99188674de5596053da5c33ebd90c603e396504047996')
17 # pytest-runner is certainly not required to build a wheel...
18 sed -e '/pytest-runner/d' -i $_name-$pkgver/setup.py
23 python -m build --wheel --no-isolation
27 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
30 # install to temporary location, as importlib is used
31 python -m installer --destdir=test_dir dist/*.whl
32 export PYTHONPATH="test_dir/$site_packages:$PYTHONPATH"
33 pytest -vv --ignore test_dir/
38 python -m installer --destdir="$pkgdir" dist/*.whl
39 install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
42 # vim:set ts=2 sw=2 et: