archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytest-ruff / trunk / PKGBUILD
blob3f3b75078231f9760e4ad1692e6fc7a59ab18890
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-pytest-ruff
4 pkgver=0.0.6
5 _commit=e9f7cdac19c938d98bf045fa21ad9ddf82896426
6 pkgrel=1
7 pkgdesc="Pytest plugin to check ruff requirements"
8 url="https://github.com/buserbrasil/pytest-ruff"
9 license=('MIT')
10 arch=('any')
11 depends=('python' 'python-pytest' 'python-ruff')
12 makedepends=('git' 'python-build' 'python-installer' 'python-poetry-core'
13              'python-poetry-dynamic-versioning')
14 checkdepends=('python-pytest-mock')
15 source=("git+https://github.com/buserbrasil/pytest-ruff.git#commit=$_commit")
16 sha512sums=('SKIP')
18 build() {
19   cd pytest-ruff
20   python -m build -nw
23 check() {
24   cd pytest-ruff
25   python -m pytest
28 package() {
29   cd pytest-ruff
30   python -m installer -d "$pkgdir" dist/*.whl
31   install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/