archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-pytz / repos / community-any / PKGBUILD
blob4086887e143e17650c3e3dd0c5dd1b3de27b1583
1 # Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
2 # Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
3 # Contributor: Douglas Soares de Andrade <dsa@aur.archlinux.org>
4 # Contributor: William Rea <sillywilly@gmail.com>
6 pkgname=python-pytz
7 pkgver=2023.3
8 pkgrel=1
9 arch=('any')
10 url="https://pypi.python.org/pypi/pytz"
11 license=("MIT")
12 pkgdesc="Cross platform time zone library for Python"
13 depends=('python')
14 makedepends=('python')
15 source=("https://pypi.io/packages/source/p/pytz/pytz-${pkgver}.tar.gz"
16         "0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch")
17 sha512sums=('3a39e9ec22bf1468e7415f60f10bf4a4e5b0b12bea2aeec45c5e63a916136c747fa0abd1b0612a99da962e743f28f24ebc43c1d73d96f0e98f7fb0ae6b62e319'
18             '3cbd497313c3049a2ae04298118aefb6dfa9ec4626078c665c95c13a78ae944b33a68813aea0c53b02b0532b64221cca4a0cd2153bd91b3760916bc3c0f6df8f')
19 validpgpkeys=('C7ECC365AB6F255E1EB9BA1701FA998FBAC6374A')
21 prepare() {
22     cd pytz-$pkgver
24     patch -p2 -i ../0001-Use-the-system-zoneinfo-from-the-tzdata-package.patch
25     rm -r pytz/zoneinfo/
28 build(){
29     cd pytz-$pkgver
30     python setup.py build
33 check(){
34     cd pytz-$pkgver/pytz/tests
36     python3 test_tzinfo.py
39 package(){
40     cd pytz-$pkgver
42     python3 setup.py install --root="$pkgdir"/
44     install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE