archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-requests-file / repos / community-any / PKGBUILD
blob4f211b77ec1c55cf7157f60526585c7d51c182ea
1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Contributor: lilydjwg <lilydjwg@gmail.com>
4 pkgname=python-requests-file
5 pkgver=1.5.1
6 pkgrel=6
7 pkgdesc="File transport adapter for Requests"
8 arch=('any')
9 url="https://github.com/dashea/requests-file"
10 license=('Apache')
11 depends=('python-six' 'python-requests')
12 makedepends=('python-setuptools')
13 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dashea/requests-file/archive/${pkgver}.tar.gz")
14 sha256sums=('a9b0a80675727f320cd5c71d6eb70cc3969b468dc27896a893148c0f6b424446')
16 build() {
17   cd "$srcdir"/requests-file-${pkgver}
19   python setup.py build_ext --inplace
20   python setup.py build
23 package() {
24   cd "$srcdir"/requests-file-${pkgver}
26   python setup.py install --skip-build --root="$pkgdir" --optimize=1