1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Oliver Sherouse <oliver DOT sherouse AT gmail DOT com>
3 # Contributor: David Scholl <djscholl@gmail.com>
4 # Contributor: David Pretty <david.pretty@gmail.com>
9 pkgdesc='A very simple, yet robust, Python interface to the R Programming Language'
11 url='https://rpy2.github.io/'
12 license=(MPL GPL LGPL)
13 depends=(python-cffi python-numpy python-pytz python-tzlocal python-jinja r)
14 makedepends=(python-build python-installer python-setuptools python-wheel)
15 checkdepends=(python-pytest)
16 optdepends=('python-pandas: conversion between rpy and pandas')
17 source=(https://pypi.io/packages/source/r/rpy2/rpy2-$pkgver.tar.gz)
18 sha256sums=('0d3e554dac8f4e55a28932f2946341aae3e02894304e1198547222aa86b89e21')
22 python -m build --wheel --no-isolation
27 PYTHONPATH="$PWD"/`echo build/lib.*` \
28 pytest -v -k 'not test_rendertofile and not test_rendertobytes_plot' # Skip test that segfaults in build server
34 python -m installer --destdir="$pkgdir" dist/*.whl