1 # Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
2 # Maintainer: Bruno Pagani <archange@archlinux.org>
3 # Contributor: Martino Pilia <martino.pilia@gmail.com>
4 # Contributor: Ben Greiner <code-arch@bnavigator.de>
6 pkgname=python-scikit-build
9 pkgdesc="Improved build system generator for CPython C, C++, Cython and Fortran extensions"
11 url="https://scikit-build.org"
13 depends=(cmake python-distro python-packaging python-setuptools python-wheel)
14 makedepends=(git python-build python-installer python-hatchling python-hatch-vcs python-hatch-fancy-pypi-readme)
25 python-pytest-virtualenv
30 _tag=6e47f59cb4c0057e5559e02c4d30a0619f636d30 # git rev-parse ${pkgver}
31 source=(git+https://github.com/scikit-build/scikit-build.git#tag=${_tag}?signed)
33 validpgpkeys=(2FDEC9863E5E14C7BC429F27B9D0E45146A241E8) # Henry Schreiner <hschrein@cern.ch>
37 python -m build --wheel --no-isolation
43 sed -i 's|\"--cov\"\, \"--cov-report=xml\"||' noxfile.py
44 # Tests need a rw version of site-packages
45 python -m venv --system-site-packages test-env
46 # https://github.com/scikit-build/scikit-build/issues/727
47 test-env/bin/python /usr/bin/pytest -vv --color=yes || echo "Tests failed"
52 python -m installer --destdir="$pkgdir" dist/*.whl
53 install -Dm644 LICENSE -t "${pkgdir}"/usr/share/licenses/${pkgname}/