1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
3 # Contributor: Patrice Peterson <runiq at archlinux dot us>
4 # Contributor: JonnyJD <arch@JonnyJD.net>
6 pkgname=python-secretstorage
10 pkgdesc="Securely store passwords and other private data using the SecretService DBus API"
12 url="https://github.com/mitya57/secretstorage"
14 depends=('python-cryptography' 'python-jeepney')
15 makedepends=('python-setuptools')
16 checkdepends=('org.freedesktop.secrets' 'xorg-server-xvfb')
17 source=("https://pypi.io/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
18 sha512sums=('9a048c8245cfb01babebdd85dbbe84f9634b9b28188f7d11d3abad841109cfa307861de05e529199e409e595864ff3e097fcc961fcff210040d214a50f932f6e')
29 dbus-launch xvfb-run -a python -m unittest discover -s tests || echo "Tests failed"
35 python setup.py install --root="$pkgdir" -O1
36 install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE