archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-securesystemslib / trunk / PKGBUILD
blob917cd2bbd1e9574c0652e565346dbf82ee505828
1 # Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
3 pkgname=python-securesystemslib
4 pkgver=0.23.0
5 pkgrel=2
6 pkgdesc="Cryptographic and general-purpose routines for Secure Systems Lab projects at NYU"
7 arch=('any')
8 license=('MIT')
9 url="https://github.com/secure-systems-lab/securesystemslib"
10 depends=('python-cryptography' 'python-pynacl' 'python-colorama' 'python-six' 'python-dateutil')
11 makedepends=('python-setuptools' 'git')
12 source=("git+https://github.com/secure-systems-lab/securesystemslib.git?signed#tag=v${pkgver}")
14 sha512sums=('SKIP')
16 validpgpkeys=(
17     "C2FB9C910758B6827BC43233BC0C6DEDD5E5CC03"
18     # Sebastien Awwad (upstream co-maintainer)
19     "8BA69B87D43BE294F23E812089A2AD3C07D962E8"
20     # Lukas Puehringher (upstream maintainer)
21     "903BAB73640EB6D65533EFF3468F122CE8162295"
22     # Santiago Torres-Arias <santiago@archlinux.org> (upstream co-maintainer)
23     "08F3409FCF71D87E30FBD3C21671F65CB74832A4"
24     # Joshua Lock (GPG on YubiKey) <jlock@vmware.com> (upstream co-maintainer)
25     )
27 build() { 
28     cd "${srcdir}/securesystemslib"
29     python setup.py build
32 package_python-securesystemslib() {
34     cd "securesystemslib"
35     python setup.py install --root="${pkgdir}/" --optimize=1
36     install -D -m0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
39 check() {
40     cd "securesystemslib/tests/"
41     PYTHONPATH=.. python aggregate_tests.py