archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-sphinxcontrib-apidoc / repos / community-any / PKGBUILD
blobdca773e9f1af5164bf5349456ea8ea9b60421590
1 # Maintainer:
2 # Contributor: Liam Timms <timms5000@gmail.com>
3 # Contributor: Patrice Peterson <runiq at archlinux dot us>
5 pkgname=python-sphinxcontrib-apidoc
6 pkgver=0.3.0
7 pkgrel=3
8 pkgdesc='A Sphinx extension for running 'sphinx-apidoc' on each build'
9 arch=(any)
10 url='https://github.com/sphinx-contrib/apidoc'
11 license=(BSD)
12 depends=(python-sphinx python-pbr)
13 makedepends=(python-build python-installer python-setuptools python-wheel)
14 source=("https://pypi.io/packages/source/s/sphinxcontrib-apidoc/sphinxcontrib-apidoc-$pkgver.tar.gz")
15 sha256sums=('729bf592cf7b7dd57c4c05794f732dc026127275d785c2a5494521fdde773fb9')
17 build() {
18   cd sphinxcontrib-apidoc-$pkgver
19   python -m build --wheel --no-isolation
23 package() {
24   cd sphinxcontrib-apidoc-$pkgver
25   python -m installer --destdir="$pkgdir" dist/*.whl
26   install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"