1 # Maintainer: Daniel M. Capella <polyzen@archlinux.org>
3 _name=sphinxcontrib-htmlhelp
4 pkgname=python-sphinxcontrib-htmlhelp
7 pkgdesc='Sphinx extension which renders HTML help files'
9 url=https://github.com/sphinx-doc/sphinxcontrib-htmlhelp
11 makedepends=('python-build' 'python-installer' 'python-setuptools'
13 checkdepends=('python-html5lib' 'python-pytest' 'python-sphinx')
14 source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
15 sha256sums=('0cbdd302815330058422b98a113195c9249825d681e18f11e8b1f78a2f11efff')
16 b2sums=('922921a52c421bde9787df6fd5107a515bb0af4f4a6a6c8b84f474b9d7b0ce9251437b8780b3464190e494555bbe6d72604e155bce98794c36c03ddbcc5c4cc7')
20 python -m build --wheel --skip-dependency-check --no-isolation
30 python -m installer --destdir="$pkgdir" dist/*.whl
32 # Symlink license file
33 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
34 install -d "$pkgdir"/usr/share/licenses/$pkgname
35 ln -s "$site_packages"/sphinxcontrib_htmlhelp-$pkgver.dist-info/LICENSE \
36 "$pkgdir"/usr/share/licenses/$pkgname/LICENSE