archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-sphinxcontrib-newsfeed / repos / community-any / PKGBUILD
blob4c6fa7b9fbddc3ac0d90af44c94b81f2ff10a551
1 # Maintainer: David Runge <dave@sleepmap.de>
2 # Contributor: eolianoe <eolianoe At GoogleMAIL DoT com>
3 # Contributor: kang <kang@insecure.ws>
5 _name=sphinxcontrib-newsfeed
6 pkgname=python-sphinxcontrib-newsfeed
7 pkgver=0.1.4
8 pkgrel=14
9 pkgdesc="News Feed extension for Sphinx"
10 arch=('any')
11 url="https://github.com/Cyclododecene/newsfeed"
12 license=('BSD')
13 depends=('python-sphinx')
14 makedepends=('python-setuptools')
15 source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
16 sha512sums=('96d9d0c15fca8b62f945bafc8f0eafa62df9c471f7510e2f153e47b66534e5f3041e5c01df772e6c35a9f09baa70064642f7f0fa43ccfd33dd64c2604494f2fc')
18 build() {
19   cd "${_name}-${pkgver}"
20   python setup.py build
23 package() {
24   cd "${_name}-${pkgver}"
25   python setup.py install --skip-build \
26     --optimize=1 \
27     --prefix=/usr \
28     --root="${pkgdir}"
29   # license
30   install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
31   install -vDm 644 README -t "${pkgdir}/usr/share/doc/${pkgname}"