1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-tenacity
5 _commit=548c5d490187af6f339cbffdd0add38aecc3ecb0
7 pkgdesc='Retry code until it succeeeds'
10 url='https://github.com/jd/tenacity'
12 optdepends=('python-tornado: for Tornado coroutines support')
13 makedepends=('git' 'python-setuptools-scm')
14 checkdepends=('python-pytest' 'python-tornado' 'python-typeguard')
15 source=("git+https://github.com/jd/tenacity.git#commit=$_commit" "fix-tests-for-typeguard-3.patch")
17 'a57faa9ddc1dd5a78d67691f5023b723fdd3fd643c3c3389f446244962f8c410e7f1a7d34b705e1488a4ea443f7cc6b716eff5bc354a7c1ac449fc65c6c869f0')
21 patch -Np1 -i ${srcdir}/fix-tests-for-typeguard-3.patch
36 python setup.py install --root="$pkgdir" --optimize=1