1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Simon Sapin <simon dot sapin at exyr dot org>
3 # Contributor: Kyle Keen <keenerd@gmail.com>
5 pkgname=python-text-unidecode
8 pkgdesc="The most basic Text::Unidecode port"
9 url="https://github.com/kmike/text-unidecode"
10 license=('PerlArtistic')
13 makedepends=('python-setuptools')
14 checkdepends=('python-pytest-runner')
15 source=("https://pypi.io/packages/source/t/text-unidecode/text-unidecode-$pkgver.tar.gz")
16 sha512sums=('aeaf0e79bd0545ca7a4fe700d5a7dac1d5900841fcfe8a5a568c84ba7d3bee5f75eaac0531f4a01d689a550ac5bc7e1acaeb8132293f220db8387fae2eb6a150')
19 cd "$srcdir"/text-unidecode-$pkgver
24 cd "$srcdir"/text-unidecode-$pkgver
25 python setup.py pytest
29 cd text-unidecode-$pkgver
30 python3 setup.py install --root="$pkgdir" --optimize=1