archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-tiny-proxy / repos / community-any / PKGBUILD
blobc54267e60a2f92cc746680571841a81f0284451d
1 # Maintainer:
3 _pyname=tiny-proxy
4 pkgname=python-$_pyname
5 pkgver=0.1.1
6 pkgrel=1
7 pkgdesc='Simple proxy server (SOCKS4(a), SOCKS5(h), HTTP tunnel)'
8 arch=(any)
9 url='https://github.com/romis2012/tiny-proxy'
10 license=(Apache)
11 depends=(python-anyio)
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 checkdepends=(python-pytest python-trustme python-aiohttp python-httpx)
14 source=(https://github.com/romis2012/tiny-proxy/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('31e2de8780046c824e04ca75fe98e7f2ce0f3b3add263c91530718043b8a869e')
17 build() {
18   cd $_pyname-$pkgver
19   python -m build --wheel --no-isolation
22 # Need more AUR dependencies
23 #check() {
24 #  cd $_pyname-$pkgver
25 #  python -m venv --system-site-packages test-env
26 #  test-env/bin/python -m installer dist/*.whl
27 #  test-env/bin/python -m pytest
30 package() {
31   cd $_pyname-$pkgver
32   python -m installer --destdir="$pkgdir" dist/*.whl
33   install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname