4 pkgname=python-$_pyname
7 pkgdesc='Simple proxy server (SOCKS4(a), SOCKS5(h), HTTP tunnel)'
9 url='https://github.com/romis2012/tiny-proxy'
11 depends=(python-anyio)
12 makedepends=(python-build python-installer python-setuptools python-wheel)
13 checkdepends=(python-pytest python-trustme python-aiohttp python-httpx)
14 source=(https://github.com/romis2012/tiny-proxy/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('31e2de8780046c824e04ca75fe98e7f2ce0f3b3add263c91530718043b8a869e')
19 python -m build --wheel --no-isolation
22 # Need more AUR dependencies
25 # python -m venv --system-site-packages test-env
26 # test-env/bin/python -m installer dist/*.whl
27 # test-env/bin/python -m pytest
32 python -m installer --destdir="$pkgdir" dist/*.whl
33 install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/licenses/$pkgname