1 # Maintainer: Caleb Maclennan <caleb@alerque.com>
2 # Contributor: Eli Schwartz <eschwartz@archlinux.org>
3 # Contributor: Felix Yan <felixonmars@archlinux.org>
4 # Contributor: Simon Sapin <simon dot sapin at exyr dot org>
5 # Contributor: Kyle Keen <keenerd@gmail.com>
8 _pyname=${pkgname#python-}
11 pkgdesc='A complete yet simple CSS parser for Python'
12 url="https://pypi.python.org/pypi/${pkgname#python-}"
17 python-{build,installer,wheel}
19 checkdepends=(python-pytest)
20 _archive="$_pyname-$pkgver"
21 source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
22 sha256sums=('12306fb50e5e9e7eaeef84b802ed877488ba80e35c672867f548c0924a76716e')
27 # isort is not a sign of failing code
28 sed -i -e '/addopts/d' setup.cfg
38 local _pyver=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
39 export PYTHONPATH="$PWD/lib.linux-$CARCH-cpython-$_pyver"
40 export TINYCSS_SKIP_SPEEDUPS_TESTS=true
46 python -m installer -d "$pkgdir" dist/*.whl
47 install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE