1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
4 pkgname="python-${_pkgname}"
7 pkgdesc="Contains the code for the PlottableHistogram Protocol, to be used in type checking libraries wanting to conform to the protocol."
9 url='https://github.com/scikit-hep/uhi'
11 depends=('python-numpy' 'python-typing_extensions' 'root')
12 makedepends=('git' 'python-build' 'python-installer' 'python-hatch-vcs' 'python-hatchling')
13 checkdepends=('python-pytest' 'python-boost-histogram' 'python-importlib-metadata')
14 source=("${pkgname}-${pkgver}::git+${url}#tag=v${pkgver}")
18 cd ${pkgname}-${pkgver}
19 python -m build --wheel --no-isolation
23 cd "${srcdir}/${pkgname}-${pkgver}"
24 python -m venv --system-site-packages test-env
25 test-env/bin/python -m installer dist/*.whl
26 test-env/bin/python -m pytest
30 cd "${srcdir}/${pkgname}-${pkgver}"
31 python -m installer --destdir="${pkgdir}" dist/*.whl
32 install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"