archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-uhi / repos / community-any / PKGBUILD
blobea67996767d431a3199393093e6199bc3511cdf5
1 # Maintainer: Konstantin Gizdov <arch at kge dot pw>
3 _pkgname='uhi'
4 pkgname="python-${_pkgname}"
5 pkgver='0.3.3'
6 pkgrel=2
7 pkgdesc="Contains the code for the PlottableHistogram Protocol, to be used in type checking libraries wanting to conform to the protocol."
8 arch=('any')
9 url='https://github.com/scikit-hep/uhi'
10 license=('MIT')
11 depends=('python-numpy' 'python-typing_extensions' 'root')
12 makedepends=('git' 'python-build' 'python-installer' 'python-hatch-vcs' 'python-hatchling')
13 checkdepends=('python-pytest' 'python-boost-histogram' 'python-importlib-metadata')
14 source=("${pkgname}-${pkgver}::git+${url}#tag=v${pkgver}")
15 sha256sums=('SKIP')
17 build() {
18   cd ${pkgname}-${pkgver}
19   python -m build --wheel --no-isolation
22 check() {
23   cd "${srcdir}/${pkgname}-${pkgver}"
24   python -m venv --system-site-packages test-env
25   test-env/bin/python -m installer dist/*.whl
26   test-env/bin/python -m pytest
29 package() {
30   cd "${srcdir}/${pkgname}-${pkgver}"
31   python -m installer --destdir="${pkgdir}" dist/*.whl
32   install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"