archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-ulid-transform / trunk / PKGBUILD
blob85ec6c1224e3264723a47bd2e07f42b3090ece63
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Lukasz Pozarlik <lpozarlik@gmail.com>
4 pkgname=python-ulid-transform
5 pkgver=0.7.2
6 pkgrel=2
7 pkgdesc='Create and transform ULIDs'
8 arch=(x86_64)
9 url=https://github.com/bdraco/ulid-transform
10 license=(MIT)
11 depends=(
12   gcc-libs
13   glibc
14   python
16 makedepends=(
17   cython
18   git
19   python-build
20   python-installer
21   python-poetry-core
22   python-setuptools
23   python-wheel
25 _tag=1ae85af96687c4f3f082750fe84c49fc0d2b3901
26 source=(git+https://github.com/bdraco/ulid-transform.git#tag=${_tag})
27 b2sums=(SKIP)
29 pkgver() {
30   cd ulid-transform
31   git describe --tags | sed 's/^v//'
34 build() {
35   cd ulid-transform
36   python -m build --wheel --no-isolation
39 package() {
40   python -m installer --destdir="${pkgdir}" ulid-transform/dist/*.whl
41   install -Dm 644 ulid-transform/LICENSE -t "${pkgdir}"/usr/share/licenses/python-ulid-transform/
44 # vim: ts=2 sw=2 et: