archrelease: copy trunk to community-any
[ArchLinux/community.git] / python-voluptuous-serialize / trunk / PKGBUILD
blob2eda52c8db47764d6ea6bf04d98c110d15e0fbcf
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
2 # Contributor: Jameson Pugh <imntreal@gmail.com>
4 pkgname=python-voluptuous-serialize
5 pkgver=2.6.0
6 pkgrel=2
7 pkgdesc='Convert voluptuous schemas to JSON'
8 arch=(any)
9 url=https://github.com/balloob/voluptuous-serialize
10 license=(APACHE)
11 depends=(python-voluptuous)
12 makedepends=(
13   git
14   python-setuptools
16 checkdepends=(python-pytest)
17 _tag=2a6c0474e9d19c07c1edd5adbd42f434a46658e2
18 source=(git+https://github.com/balloob/voluptuous-serialize.git#tag=${_tag})
19 b2sums=(SKIP)
21 pkgver() {
22   cd voluptuous-serialize
23   git describe --tags
26 build() {
27   cd voluptuous-serialize
28   python setup.py build
31 check() {
32   cd voluptuous-serialize
33   PYTHONPATH=$PWD/build/lib pytest
36 package() {
37   cd voluptuous-serialize
38   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
41 # vim: ts=2 sw=2 et: