1 # Maintainer: Filipe LaĆns (FFY00) <lains@archlinux.org>
4 pkgname=python-$_pkgname
7 pkgdesc='A friendly library for parsing HTTP request arguments, with built-in support for popular web frameworks'
9 url='https://github.com/marshmallow-code/webargs'
11 depends=('python-marshmallow')
12 makedepends=('python-setuptools' 'python-sphinx' 'python-sphinx-issues' 'python-sphinx-typlog-theme' 'python-sphinx-furo')
13 checkdepends=('python-pytest-runner' 'python-webtest' 'python-pytest-aiohttp' 'python-webtest-aiohttp'
14 'python-bottle' 'python-werkzeug' 'python-django' 'python-flask' 'python-tornado' 'python-pytest-asyncio')
15 source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
16 sha512sums=('9fc223b70333afe0985ff90648d6f59c94c97b87386df156038e3a6f7c0ac59526181d0a20107df6e060fe0fc9750de9144cbf2c07011cd54840000758eeedd5')
21 rm tests/test_{falcon,pyramid}parser.py
33 gzip _build/man/webargs.1
39 python setup.py pytest
45 python setup.py install --root="$pkgdir" --optimize=1 --skip-build
47 install -dm 755 "$pkgdir"/usr/share/doc/$pkgname
48 cp -r -a --no-preserve=ownership docs/_build/html "$pkgdir"/usr/share/doc/$pkgname
50 install -dm 755 "$pkgdir"/usr/share/man/man1
51 install -Dm 644 docs/_build/man/webargs.1.gz "$pkgdir"/usr/share/man/man1/webargs.1.gz
53 install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
56 # vim:set ts=2 sw=2 et: